HOME DOWNLOAD LICENSING GEE-OH! CONTACT
 

DiagramBuilder Help

Welcome to the DiagramBuilder Help page.

Getting Started

Upon running DiagramBuilder for the first time, you will be presented with the dialog box shown below. If you do not have your License Key already, then click the "Get License!" button.

You will be taken to the Licensing page(s). Select DiagramBuilder, if not already set, and enter the relevant details. This will register you on the system with an (at first) inactive License, and an email will be sent out.

Continue with payment via PayPal and your License then becomes activated. You will receive a further email informing you of this.

If the Licensing Dialog is still open (if not, reload the application), enter your email address and License Key in the relevant fields - ensuring the EULA box is ticked - and click 'OK'. This will attempt to verify your License on the server.

A valid response from the server indicates that your application has been verified, and will proceed to run.

DiagramBuilder will attempt to validate your License once a week. You do not need to be constantly connected to the Internet for your application to work - if, for whatever reason, you could not connect to the Licensing Server, you are given 3 days grace (after which, if you still have not verified, access to the application will be limited). Normal use will resume once you connect to the Licensing Server and verify.

The Basics

Create Node

Right click in some empty space in the working area and select "New Node" from the popup menu. You will be prompted to give the node a name (which is optional). Press Enter or click 'OK' to finish creation.

Delete Node

To delete a node, either right click within the node and select "Delete Node" from the menu, or - with the node selected - press del or ctrl+d.

Create Link

To create a link between two nodes, hold down alt (or shift+ctrl for Linux/Ubuntu) and then click and drag from one node to the other. Repeat this operation to remove links. Two way links are allowed.

Move Nodes

To move nodes, simply click and drag to the required location.

Resize Node

To resize a node, hold down shift and then click and drag from within the node to the required size. The default may be set to couple font size and node size - in which case both node body and font size will scale together. This can be toggled on/off in the Options menu.

Resize Text

To resize a node's text, hold down ctrl and then click and drag from within the node to the required size.

Rename Node

Right click on a node, and select "Rename Node". A dialog box will prompt you for the new name. An empty name is acceptable.

Bold Text

To make a node's text bold, right click and select "Bold" from the menu.

Node/Link Colour Settings

To change a node's colour settings (node body, node outline, text body, text outline), either right click on the node and select the required option from the "Colour" menu, or click on the relevant button on the top toolbar.

The colour of selected links (and any new links to be created) can also be set in this way.

Node Type

Node Type can be changed by either right clicking on the node and selecting the required option from the "Node Type" menu, or by clicking the Node Type button in the top toolbar.

Node Types:

  • Circle
  • Square
  • Diamond
  • Triangle
  • No Body
  • Text
  • Percentage

Line Type, Link Type, Line Thickness

Line Type, Link Type and Line Thickness can all be set in the top toolbar.

Group Selection

To select a group of nodes, you can click and drag a selection box around them.

You may also hold down shift whilst clicking on nodes to add/remove them from selection.

To select all nodes, press ctrl+a.

When a group of nodes is selected, most actions will affect each selected node/link identically: resize, colour change, delete, move, etc.

Cut, Copy and Paste

Nodes, groups of nodes and their associated links can be cut, copied and pasted as standard. This can be done either by right clicking on a node and selecting either "Cut Node" or "Copy Node" (followed by right clicking in an empty area and selecting "Paste Node"), or by the usual shortcut keys (ctrl+x, ctrl+c, ctrl+v respectively).

Default Settings

Default colour settings can be set via Options > Colour Settings for everything, including background colour.

Default node size and text size can be set via Options > Defaults.

Undo/Redo

As in most applications, undo/redo can be done via the Edit menu, or via the following keyboard shortcuts: ctrl+z and ctrl+y (undo and redo, respectively).

Save/Load

Saving and loading can be done via the File menu. The keyboard shortcut ctrl+s can also be used to save.

Export Image

To export your diagram as a .png image file, select File > Export. You will then be prompted to choose a name and location to save to.

The image will be exported to the exact size of the window, so resize the window accordingly before exporting.

Advanced

Snap To

If you select "Snap To" from the Edit menu, then dragged nodes will snap to the nearest node/end of line.

Snap Angle/Distance

Snap Angle and Snap Distance can be toggled on/off in the Edit menu, and these options allow you to drag nodes and make them snap to the nearest multiple of "Snap Angle" (also set in this menu), and/or to a distance of "Snap Distance" from the parent node.

Ordering Nodes

The order in which the nodes are drawn can be changed, to either push a node to the back, or bring it to the front, using the "Push To Back" or "Bring To Front" options in the right click popup menu.

Locking

If you right click on a node and select "Lock", this prevents the node from being moved, resized or rotated (except for the case of a Grouped Spatial Resize). Select the option again to remove the lock.

Grouped Spatial Resize

When a group of nodes is selected, if you hold down ctrl you will see the selection box appear, with a white dot in the top right corner. To resize the group's spatial separation, click and drag this point.

If you hold down shift as well as ctrl, this spatial resize will constrain proportions to keep ratio of width to height intact.

Group Rotation

When a group is selected and you hold down ctrl, in addition to the top right Grouped Spatial Resize point, you will also see a similar point at the centre of one of the nodes. This is the Rotation Point.

With ctrl still held, to rotate the group around this point, click and drag up or down in an empty part of the working area. You will see the angle indicator appear, to aid you in rotating to the correct amount

The rotation point can be click n' dragged like a regular node, to the desired postion, and this also obeys "Snap To".

Templates

Templates can be toggled on/off with the "Show" option in the Templates menu. Once visible, templates can be created/overwritten by dragging and dropping nodes/groups into template boxes, or repeatedly used by dragging from template boxes.

Templates can be deleted via a right click popup menu.

Template Sets can be created and selected in the Templates menu.

Icons

Nodes can have icons associated to them by right clicking the node body and selecting from the Icon menu.

You can load in a new image (which will then remain as a repeatable option in the Icon menus), or select an existing icon. This will auto-scale to the node size.

Icons can be disassociated from a node via the "Remove Icon" option.

Flow

If you set the "flow" toggle button to "on" in the top toolbar, you will see small black dots flowing along the lines in the direction of each link. This provides a quick visual indication of how "busy" each node is, and where the most connectivity is.

Primitive Drawing

DiagramBuilder allows you to draw very basic lines, boxes and circles (as a collection of lines), and these can be selected in the top toolbar.

Each of the options are implemented by click and drag in the working area.

Additionally, it is possible to draw free lines while still in "selection" mode by holding down alt (or shift+ctrl) and clicking and dragging in the working area. Releasing alt or shift+ctrl will return to "selection" mode.

URL Embedding

You can associate a URL to a node via the "URL" option in the right click popup menu. For a node that has a URL associated, it will display a blue outline and you will see the mouse pointer change to signify a web link when you hover over it.

To open this web link in a browser, hold down ctrl and click on the node.

Node Notes

Nodes can have notes attached to them via the "Notes" option in the right click popup menu. Clicking this will bring up the Notes Editor, where you can enter your notes and then click 'OK' to apply them.

If the "Show Notes on Rollover" option is enabled in the Options menu, you will see those notes pop up when you hover over the node.

Sub-Diagrams

If you want your diagram to contain various levels of complexity (for example, some basic "high-level" nodes, with a range of sub-nodes attached for those that wish to "drill-down"), then the Sub-Diagram feature will be of use to you.

To create a Sub-Diagram, right click on the desired node and select "Add Sub-Diagram" from the popup menu. This will create a new Sub-Diagram, which contains only the previously chosen node (which serves as a link between the two diagrams).

Nodes which act as links between Sub-Diagrams are rendered slightly differently for identification.

You will see the Diagram Selection Bar appear in the top left of the working area, showing which level is currently selected and allowing you to click to select levels. The Diagram Selection Bar updates as you add/remove diagrams.

You can also navigate up/down diagram levels by double-clicking on nodes that are linked to other diagrams, or use the following keyboard shortcuts to navigate up/down respectively: alt+Up and alt+Down.

Sub-Diagrams can be removed by right clicking on the "parent" node and selecting "Remove Sub-Diagram" from the popup menu.

Video Demonstrations

Basic Features

Advanced Features

 
  © Zack's Mohawk Limited 2017